If you use 1and 1.com as your hosting provider, this will fix the problem. WordPress is getting confused by the presence of both PHP4 and PHP5 on your shared web host.

The solution is to add the following lines in the WordPress .htaccess file (located in the main WordPress Folder ) Add these lines to the very top of your .htaccess page code:


# Ensure PHP5 being used
# For WordPress auto upgrade
AddType x-mapp-php5 .php
AddHandler x-mapp-php5 .php